Powerful Outlook Add-ins

Service Support Forum for DS Development Add-ins and Utilities
It is currently Fri Nov 16, 2018 6:54 pm

All times are UTC




Post new topic Reply to topic  [ 12 posts ] 
Author Message
 Post subject: Sender Filter Problem
PostPosted: Fri Oct 26, 2007 7:01 pm 
Offline

Joined: Mon May 07, 2007 3:35 pm
Posts: 10
I have owed a couple copies of this for awhile. I remember this being a problem when I first bought it but ended up using some outlook filters to get around the problem. The work around doesn't really solve the full problem but helps a bit.

Anyways I have all my domains forward the mails to my gmail account, then I have outlook retrieve them from there. The problem is the Sender Filter to only send email the first time per sender seems to go by my email address now the senders. This causes only the first email to get a response and it is seems to think the rest are not unique senders. I would think it should go by the original sender of the email and not the emails it get forwarded to.

My setup is all emails to a domain are forwarded to a main email email on that domain. That main email then forwards them all off to gmail. Outlook retrieves them from gmail and autoreplies to the ones that are requesting information.

Example:
forsale@mydomaindotcom
domaininfo@mydomaindotcom
webmaster@mydomaindotcom

these all forward to
admin@mydomaindotcom

all emails received by mailto:admin@mydomain.com are sent to mygmailforspamfilter@gmaildotcom

outlook retrieves mail from mygmailforspamfilter@gmaildotcom

Now if I leave off the one time per sender the replier part of ARM uses the original sender and replies to it, not sure why the Sender Filter looks at my email instead of the original sender as well. It seems to be looking at one of my @mydomaindotcom emails or mygmailforspamfilter@gmaildotcom so it only replies to th first one received. Can someone please test this and maybe it's an easy fix so I don't have to find a new product.



Top
 Profile  
Reply with quote  
PostPosted: Sat Oct 27, 2007 7:22 am 
Offline
Site Admin
User avatar

Joined: Thu Mar 25, 2004 1:52 pm
Posts: 669
Are the emails forwarded or redirected to your gmail account?

On a regular forward, the original sender address is replaced by the address from where you do the forward, so we can't do much about it. If it's a redirected message or a message sent "on behalf of" please edit your rules and make sure you mark the option to reply to the original sender.

_________________
--------------
DS Development
Outlook Add-ins and Outlook Productivity Solutions
--------------
http://www.outlook-apps.com



Top
 Profile  
Reply with quote  
PostPosted: Fri Nov 02, 2007 5:18 am 
Offline

Joined: Mon May 07, 2007 3:35 pm
Posts: 10
They are forwarded but I don't think you read it all correctly. It does reply to the original sender thats not the problem. The Sender Filter is the problem.

If I do not include check the Only one time in Sender Filter then it replies to the original sender so ARM must know the original sender correct?

How does the Sender Filter use a different sender to check the database of sent mails then the Rule Action that Replies to the sender? Shouldn't they both use the same info?

I'll do more testing if you don't understand what is going on but if I forward all my email addresses to one main gmail account then pop the mail from that account only the first email gets a reply(even though all the mails are from different people). If the filter looks at the reply to email like ARM does when it sends a reply it should work fine. All my replies don't go to the gmail account, they do to the original senders so not sure why the Sender Filter works that way.

Personally I think the problem is the Sender Filter is not checking the original sender but is checking some other email in the header(maybe one of my emails that forwarded the mail to the pop gmail account? if so that would be incorrect). If it checked the original sender, the same one that the reply action uses when sending a reply then there wouldn't be any problems. It should be checking that email address anyways should it not? That's the email address the mail would go to if it doesn't get filtered out by the SenderHistory so that's the one it should be checking in Sender Filter.



Top
 Profile  
Reply with quote  
PostPosted: Mon Nov 05, 2007 7:04 pm 
Offline

Joined: Mon May 07, 2007 3:35 pm
Posts: 10
I need to know if this is fixable and if so can be a quick fix/release. Otherwise I will need to look for an alternative and request a refund for the licences I purchased.



Top
 Profile  
Reply with quote  
PostPosted: Mon Nov 05, 2007 8:47 pm 
Offline
Site Admin
User avatar

Joined: Thu Mar 25, 2004 1:52 pm
Posts: 669
We released an update today, can you please download it and try it? You can download it by clicking on "Check for Updates" from your Auto Reply Manager toolbar.



Top
 Profile  
Reply with quote  
PostPosted: Wed Nov 07, 2007 9:58 am 
Offline
Site Admin
User avatar

Joined: Thu Mar 25, 2004 1:52 pm
Posts: 669
I am posting the same message that I emailed you, just in case:

Can you please open the ARM log (click on Show Log from the ARM toolbar) and see if there are any entries listed with a red icon? If there are, what is the error message?

Let’s try to simply the scenario, honestly it is a little confusing and I’m not sure I got it right…

So you have account A defined as a POP account in Outlook. You want to be able to auto-reply to messages received on it (only 1 time per sender). You also setup account B on gmail which is configured from the gmail interface to forward the emails to account A.

You tested by setting up 2 test gmail accounts: account C and account D. Then you sent test emails from C and D to B, which redirected them to A. Then, Outlook retrieved the emails from account A and you want it to reply to the original senders (reply to account C and D). You are saying that it replied to account C, but it did not reply to account D?

Is the above scenario correct?



Top
 Profile  
Reply with quote  
PostPosted: Tue Mar 03, 2009 4:05 am 
Offline

Joined: Tue Mar 03, 2009 3:40 am
Posts: 4
Hello, I just downloaded the latest version from your website today.

I have seen a lot of people complain about the Send filter and I'm having the same problem as bogdan too. If people use the forwarding functionality in Gmail (or probably any email service), ARM only works if the the "For all incoming messages of the same sender" is selected, even though the "From:" address is actually different for every single email. And the other two radio button options in the Send Filter do not work in this case.

For example, below I have highlighted the headers from one of my emails that was completely ignored. The reason it was ignored is because ARM seems to only look at the "Return-Path" to determine the sender, but when we use Gmail for Craigslist or other ad posting campaigns and forward those emails from Gmail to another account, the Return-Path is not the correct address for ARM to reply to.

So in my example below, the simple "From:" address is what ARM should be replying to (because I don't want to reply to my Gmail forwarding account), but ARM doesn't work in this very popular situation because ARM only looks at the Return-Path. Please let me know when this will be resolved and then I will purchase your software.

Thank you.

Return-Path: <email1@yahoo.com>
Received: from web57610.mail.re1.yahoo.com (web57610.mail.re1.yahoo.com [66.196.100.92])
by mx.google.com with SMTP id 9si1100863yws.55.2009.03.02.19.46.10;
Mon, 02 Mar 2009 19:46:10 -0800 (PST)
.......
From: <email2@gmail.com>



Top
 Profile  
Reply with quote  
PostPosted: Wed Mar 04, 2009 11:40 am 
Offline

Joined: Wed Feb 11, 2009 5:53 pm
Posts: 212
Please try to use the desired rule with the "Reply to original sender" option unmarked.
I also replyed to you by email.

Kind Regards,

Andrew Smith
DS Development Support Team

_________________
Best Regards,
Andrew Smith
Service Support Dept., DS Development
http://www.outlook-apps.com
Email Productivity Blog
Follow us on Twitter
Join our Facebook Fan Page
Email: support@outlook-apps.com



Top
 Profile  
Reply with quote  
PostPosted: Wed Mar 04, 2009 9:05 pm 
Offline

Joined: Tue Mar 03, 2009 3:40 am
Posts: 4
Hello Andrew,

Thanks for your reply. I already tried unmarking the "Reply to original sender" option, but it still ignores the incoming messages from the sender indicated in the "FROM:" field. It simply ignores the "FROM:" sender and does not execute the very simple rule I've defined.

I've pasted all the header information below (and anonymized the email addresses of course) so you can see exactly what is going on. The From: <ORIGINAL.FROM.ADDRESS@gmail.com> is the address that ARM should be autoresponding to, but it's completely ignoring it. I'm not sure why it's so difficult to make ARM simply read the FROM: address and reply to it (and only reply once if the "Only reply one time" option that has also been selected).

I know the "FROM:" address can be easily spoofed so the users should have an option to choose from different Sender options, but the "FROM:" address is the most obvious address that is displayed in the client to the users. So this "FROM:" address should be the first option for users to select from the Sender Filter.

Please help. And please give me an estimated time frame for how long it will take you to resolve this and update your software.

Thanks Andrew.

Image

andrew_dsd wrote:
Please try to use the desired rule with the "Reply to original sender" option unmarked.
I also replyed to you by email.

Kind Regards,

Andrew Smith
DS Development Support Team



Top
 Profile  
Reply with quote  
PostPosted: Thu Mar 05, 2009 1:30 pm 
Offline

Joined: Wed Feb 11, 2009 5:53 pm
Posts: 212
Hi,

How are the emails generated? Using Send-As option from Outlook or using a server script?
You also tried with the option "Reply to original sender" unmarked?
As per our tests replying to the from address should be working fine...
Is it possible that you send a copy of one of these emails to mailto:support@emailaddressmanager.com so we can test it?


Kind Regards,

Andrew Smith
DS Development Support Team

_________________
Best Regards,
Andrew Smith
Service Support Dept., DS Development
http://www.outlook-apps.com
Email Productivity Blog
Follow us on Twitter
Join our Facebook Fan Page
Email: support@outlook-apps.com



Top
 Profile  
Reply with quote  
PostPosted: Thu Mar 05, 2009 6:22 pm 
Offline

Joined: Tue Mar 03, 2009 3:40 am
Posts: 4
Hi Andrew,

I've sent you a detailed reply with one of the complete emails for you to review. Please reply to the personal email that I sent you as soon as possible.

Thank you.



Top
 Profile  
Reply with quote  
PostPosted: Thu Mar 05, 2009 7:07 pm 
Offline

Joined: Tue Mar 03, 2009 3:40 am
Posts: 4
andrew_dsd wrote:
You also tried with the option "Reply to original sender" unmarked?


And yes, I've tried every possible combination, including unmarking the "Reply to original sender".



Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 12 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group